Round 1: Installation





Argument for Netscape 6.2


Dan: Installing software should be as easy as falling out of bed, only less painful. And Netscape is possibly the most painless install I've ever encountered. Simply download the 500K installation applet from the Netscape site or from CNET Download.com , then launch it at your leisure. Over DSL, the installer downloaded the whole 25MB enchilada from Netscape, set up the program, and launched the browser in less than six minutes. No muss, no fuss, and no rebooting.





Contrast that, for a moment, with Internet Explorer 6, where just getting to the right download page is a 15-minute affair. (You can save a little time by launching IE 5.x and selecting Tools > Windows Update, but you still have to wade through several Web pages and dialog boxes.) Like Netscape, IE 6 uses a 500K installer app that then goes to the Web and fetches the actual program. The installer launches automatically, then begins s-l-o-w-l-y downloading a 16.5MB update (your file size may vary, depending on which version of IE you have installed). In my informal test, the download took about 43 minutes--on DSL, no less. (Thanks to insane site traffic, my download speed was around 5Kbps.) Total elapsed time: 1 hour and 5 minutes, including a mandatory system reboot. And that's not including my first installation attempt, which crashed on me middownload.





In addition, Netscape couldn't be more accommodating to IE users. Netscape automatically imports IE Favorites upon installation. IE doesn't import Netscape bookmarks on install; you need to do it manually via the Import wizard (File > Import And Export).





And don't even think about installing IE 6 if you're running a non-Windows OS. It ain't happening. So, all you Mac enthusiasts, fuhgettaboudit.





It's no contest. Netscape takes this in a walk.





Rex's rebuttal: Please. If IE 6 is a slow download, it's because everybody is trying to upgrade right now. Netscape never suffered quite the same slowdown because a lot fewer people tried to download it. Wait another couple of weeks, and the IE 6 download should be back on a par with Netscape's. Sure, Netscape imports IE bookmarks when you install, but the result couldn't be more confusing. In some cases, when you click an "imported IE favorite," all you see is a text file displaying the bookmark's URL and cookie info. What's up with that?





And what about Netscape's nasty habit of installing a couple of AOL advertisements, disguised as bookmarks, into your existing IE Favorites? That's just rude--it's one thing for Netscape to copy bookmarks, it's another for the program to insert its own bookmarks into IE.





As for non-Windows users, Microsoft hasn't forsaken you. In fact, Microsoft built IE 5 for Macintosh from the ground up specifically for the Mac. Version 5.1, for example, is completely Carbonized, meaning that it's optimized for OS X and OS X 10.1. Traditionally, Microsoft upgrades Mac and Windows programs according to different product cycles, so be patient. Microsoft will probably release IE 5.5 or 6 for Macintosh before you know it.





Argument for Internet Explorer 6


Rex: Installation? What installation? You buy a copy of Windows, you get IE installed free! OK, maybe the Justice Department has a problem with that, but let's face it: most folks don't have to worry about installing IE because it comes with Windows (heck, it's even preinstalled on Macs). And even if for some reason you do have to install it (say, you have a version of Windows with IE 4.0 preinstalled and you've never upgraded), it's a breeze. Just download the 500K install program, select the parts you want, and the installer downloads only the components you specified.





So how do you find that little install program in the first place? Of course, I'm partial to CNET's Download.com , but for Windows 98 and later, you can also use the built-in Windows Update icon from the Start menu. What could be simpler? A couple of easy clicks from the Start menu, and you're ready to upgrade. With Netscape, you have to hunt all over the place just to find the installer program; even on the Netscape.com site, it took at least three clicks to find the installer.





And we love the fact that IE is smart enough to know which components your machine doesn't need. When the installer displays a list of components, it highlights the ones you don't need to upgrade. If, for example, you already have the latest Windows Media Player, why waste bandwidth downloading it again with IE 6? That's a cool feature that Netscape still hasn't quite figured out.





Dan's rebuttal: Hmm, let's see. Dial up the Netscape home page, click the Download button, and there's the Netscape link staring you in the face. Sounds like a vacation compared to the ordeal you face downloading anything from Microsoft. After drilling through lots of subpages and menus to find the darn file, you may have to wait 45 minutes for the download. Sheesh! So unless you want IE 6 so badly that you're willing to put up with the interminable download (or willing to upgrade to Windows XP at $100 to $200 a pop), you have to give this round to Netscape.





CNET's call: Internet Explorer 6


Vote: 5-3


It was a close call, but IE managed to eke out a win in this round. The jury decided that download speeds are affected by too many outside variables to carry much weight in the long run. Both install files are around the same size, so, all other things being equal, they cancel each other out. The deciding factor? Right or wrong, we just can't deny that as long as IE is an inextricable part of Windows, almost no Windows user will ever have to go through a full installation.








Round 2: Interface and features





Argument for Netscape 6.2


Dan: A browser is a browser is a browser, right? Well, not quite. Sure, both Netscape and IE will grab Web pages, play media files, and serve up e-mail. It's the small touches that count and, hands down, Netscape's interface is cleaner and smarter than IE's.





For example: Both browsers feature the standard complement of buttons and toolbars, but only Netscape also makes it a snap to grab a stock quote, go shopping, look for a job, or check e-mail. Just click the down arrow next to the URL location window, select "Get a stock quote" (for example), type the ticker symbol in the window, and hit Enter. Netscape launches its personal finance portal and provides a 20-minute-delayed quote. It's simplicity itself.





And let's not forget Netscape's cool themes. The browser ships with two skins , or themes--Classic and Modern--that let you change your browser's interface with a few clicks of the button. And, if you visit Netscape's Theme Park page (just click View > Apply Theme > Get New Theme), you can download any number of user-created themes, including the colorful Toy Factory and the patriotic American.





Plus, you'll love Netscape's My Sidebar feature. Press F9 (or click View > My Sidebar) to open a window on the left side of the browser with tabs labeled Sports, Music, News, Shopping, and Search, among others. You can run, say, a Google search, then keep a list of the top 10 hits open in the sidebar while you examine each page. My personal favorite is the What's Related tab, which automatically searches the Net for sites similar to the one you're currently browsing. Unlike IE's Show Related Links feature, Netscape's version updates itself as you move from one site to another. So as you move from, say, ESPN.com to CNN.com, the related links change from sports sites to news sites.





One final note: The first time you launch IE 6, it opens to an ad for Microsoft Network, regardless of your default home page. Even AOL, Netscape's parent and the king of obnoxious marketing practices, doesn't stoop that low.





Rex's rebuttal: Sure, Netscape has a pretty interface--now. The browser went through six different versions before Netscape hit on a user interface that works properly. Internet Explorer has had the same basic, usable interface since version 4.0. If it ain't broke, why fix it? And Netscape's My Sidebar has nothing on the IE 6 Media Bar, which makes it oh-so-simple to play Internet radio while cruising around on your favorite Web sites. Nor does Netscape let you rearrange toolbar icons the way you can in IE. And, on the subject of ads, what about the bookmark that the Netscape installer inserts into both your Netscape and IE favorites? It takes you to a page where you can subscribe to AOL, of course. Talk about nerve!





Argument for Internet Explorer 6


Rex: Unlike Netscape, which seems to relish changing its user interface (UI) every couple of months, Microsoft hasn't changed IE's basic browser interface significantly since version 4.0. Instead, each version introduces several handy incremental interface tweaks and perhaps some security enhancements or new menus. Anyone who's used any IE 4.x version will feel instantly comfortable with IE 6.





And, although Netscape's meager selection of themes lets you change the way your browser looks, you really can't change much of its actual operation. In that respect, IE is far more customizable: you can right-click toolbars and select the ones you want to show or hide. Uncheck View > Toolbars > Lock The Toolbars, and you can rearrange toolbars any which way by simply grabbing the toolbar in question and dragging it to the new position. You can even tear any toolbar off so that it floats in a separate window. I also love the Favorites organizer, which lets you rearrange bookmarks right in the Favorites menu--no need to open a separate window. It's all so much more intuitive and consistent than Netscape's morass of option windows and check boxes.





Dan's rebuttal: Microsoft furiously upgraded its browser every year until it killed off the competition, then got complacent. This is a good thing? I admit, Netscape's browser was in serious need of a face-lift--and it got a great one. Now it's IE's turn. Its tired UI is overdue for a nip and tuck. Anyone who's used IE faithfully since 4.0 should take a long look at Netscape 6.2; you'll like what you see.





CNET's call: Internet Explorer 6


Vote: 7-1


Not even close! Despite Netscape's groovy themes and handy My Sidebar, our jury wasn't that impressed with this browser's new clothes. The majority of us found IE more attractive and intuitive overall, and we were put off by Netscape's lack of flexibility. No contest here.








Round 3: Speed and performance





Argument for Netscape 6.2


Dan: When you're surfing the Web, every second counts, and Netscape's Gecko rendering engine is just a wee bit faster than IE's. I conducted my own informal test by using both browsers to access 10 popular Web sites over DSL. Netscape loaded pages in an average of 10.5 seconds, more than a second faster than IE did. Multiply that by the hundreds of pages I view every week, and the difference adds up.





Finally, although Netscape 6 was shakier than a belly dancer in an earthquake--just look at the thing and it would crash--versions 6.1 and 6.2 are a lot more stable. I was able to open 20 separate Netscape windows at once without a hiccup. Just try that with IE.





Rex's rebuttal: Man, I don't know what kind of Stone Age PC he's using, but in all of CNET's official tests (performed on IE 6 and Netscape 6.1), IE 6 trounces Netscape. Whether it's loading pages from the Internet or from the local browser cache, IE still outpaces Netscape by a comfortable margin. Yes, Netscape 6.x is finally competitive, but, like an Olympic silver medalist, Netscape is fast, but not quite fast enough to be the best. The gold still goes to IE.





Argument for Internet Explorer 6


Rex: Internet Explorer has been the speed champ among browsers since version 3.0 first came out. Each edition has consistently started faster and loaded Web pages more quickly than any other full-featured browser on the market. In fact, until Netscape 6.1, IE consistently ate Netscape browsers for lunch in this department, often loading Web pages twice as fast. Sure, Netscape 6.1 and 6.2 have almost caught up speedwise, but it has taken the browser a very, very long time just to reach parity.





And, hey, let's not even talk about crashes: Netscape browsers have traditionally been more crash-prone than Toonces the Driving Cat. An act as simple as loading a Web page should never cause a browser to crash. Granted, I'll admit that IE 6 still crashes occasionally, but less often than IE 5.5 and much less often than Netscape's buggy browsers.





Dan's rebuttal: You say IE is a bit faster; I say Netscape has a slight edge on IE. When it comes to speed, looks like it's a draw. In any case, stability is far more important than speed. And, while over the years both browsers have been buggier than a lollipop in an ant farm, Netscape 6.1 and 6.2 are remarkably less crash-prone. More important: When Netscape goes south, you lose only the page you had open. When IE crashes, it often takes Windows down with it--along with anything else you happen to be running.





CNET's call: It's a draw!


Vote: 4-4


Stabilitywise, it's a dead heat: like Steven Seagal, both of these browsers are hard to kill. Speedwise, IE bested Netscape when it came to loading times and surfing speed. In both of CNET's official tests, IE outpaced Netscape by a narrow margin. But IE's Windows integration means that in those rare moments when IE crashes, the browser may indeed fuzz your whole system. That fact costs IE its slight edge and leaves us with a tie.








Round 4: Security





Argument for Netscape 6.2


Dan: There's no such thing as a perfectly secure browser. Still, experts seem to uncover a new IE flaw every week. (For a sobering look at just how leaky Microsoft's browser is, check out bug hunter Georgi Guninski's list of flaws.) I'll take my chances with Netscape, thank you very much.





For one thing, Netscape makes it far easier to control your privacy and security settings. Let's say you want to change the way Netscape handles cookies. You launch the browser, select Edit > Preferences, click Privacy And Security, and select Cookies in the Category box.





Netscape displays a simple dialog box where you can enable or disable all cookies or allow only those sent from the originating site. You can click a check box to issue warnings before cookies creep in or click another a button to see what cookies your PC has already digested, then flush them from your system. The More Information button offers a long, remarkably clear discussion of privacy issues. (All Internet privacy policies should be this coherent.) Netscape offers similarly straightforward controls for passwords, encryption, authentication, and more.





Meanwhile, IE users either have to trust Microsoft and rely on its global Internet zone settings (high, medium, low) or become supergeeks. For example, to change cookie settings in IE, you must select View > Privacy Report > Settings > Advanced, and then figure out the difference between a "first-party" and a "third-party" cookie. Want to tweak your file download settings? You have to select Tools > Internet Options, the Security tab, the Internet zone, Custom Level, then wade through a long list of settings such as Allow Meta Refresh and "Navigate subframes across different domains."





At this point, I'd rather be hacked.





Rex's rebuttal: If it were easy to protect your privacy on the Internet, IE wouldn't provide you with so many security settings. I like IE 6's two-pronged approach: you can use the browser's default high, medium, and low security zones, or you can manually fine-tune and create your own security settings. Like one of those fancy Triptronic luxury cars, IE 6 will either run like an automatic transmission or let you take over and work the gears manually if you prefer. And let's face it--the only reason you don't hear about Netscape security bugs is that nobody cares enough to try and hack it. We all heard about the endless stream of bugs in Netscape 6, which must've included some security bugs as well. It's just that nobody bothered to find them because the darned browser wouldn't stay running long enough to identify the security bugs.





Argument for Internet Explorer 6


Rex: Sure, a lot of hackers have exposed security flaws in IE, but that's because all of the hackers are focusing on IE; I suspect that if the same zeal were used against Netscape, that browser might have just as many security flaws. Besides, in response to these attacks, IE developers have been forced to continually beef up the browser's security, so, in fact, it's probably more secure than any lesser browser. (As the saying goes: What doesn't kill you makes you stronger.) Microsoft constantly releases security patches for IE, and installing these patches is as easy as pie: just click the Windows Update button from the Windows Start menu. If Windows Update detects that your browser lacks a key security upgrade, you'll be guided through a simple series of downloads to install the fix. No fuss, no muss.





Dan's rebuttal: Would you keep your money in a bank that got robbed every week? Especially if the bank manager told you not to worry, they've finally decided to patch the holes in the walls and lock the doors at night? The fact that Netscape is a smaller target is a good thing. Let the hackers and virus writers attack Microsoft and leave the rest of us alone.





CNET's call: Netscape 6.2


Vote: 7-1


Here's one case where it pays to be in second place. Internet Explorer 6's very popularity makes it a constant target for malicious and mischievous hackers eager to exploit its security holes and, thus, attack the greatest number of sites and surfers. Although we don't doubt that Netscape has its design flaws, the browser's lack of visibility protects those flaws from attack. Even the lone voter who didn't think it fair to blame IE for hacker activity had to admit that, as a result, Netscape provides the safer browsing experience.











Round 5: Standards and plug-in support





Argument for Netscape 6.2


Dan: Two words: open source. That's the biggest difference between the new Netscape and the old "we are the world" Microsoft. Netscape's Gecko engine is an ongoing project involving thousands of independent software developers, all adhering to open Web standards--and making it the most compatible browser in history.





While Microsoft has grudgingly added support for some Web authoring standards--such as HTML 4.0, Cascading Style Sheets (CSS), and the Document Object Model (DOM) --it has also removed support for other popular technologies, such as Netscape-style plug-ins. Want to view QuickTime video in IE? You'll have to download a new ActiveX Control. Want to play music files using the Beatnik audio player? Sorry, it won't work at all in IE 6.





The same goes for viewing the more than 1 million Web pages that use Java applets, such as GameWeb or portions of CNN's site. It's no problem with Netscape, but new users of IE 6--for example, anyone who buys a Windows XP-based PC--will have to install a Java Virtual Machine to run the applets on these pages. (If you've upgraded from earlier versions of IE, you'll still be able to see Java.)





Whatever they say in public, Microsoft's honchos are still firm believers in the "not invented here" concept. If they didn't create it, it doesn't exist--or at least, it won't once they're through with it. Give some credit to AOL for not letting the Redmond giant destroy its last true competitor.





Ladies and gentlemen of the jury, I rest my case.





Rex's rebuttal: "Grudging" support for DOM and CSS? Hey, IE was the first browser to support both of them, and IE 6 continues that tradition with excellent support for these two key Internet standards. And, frankly, for the ordinary surfer, Java isn't really such a big deal. Sure, it's is pretty useful for people who want to write games and interactive demos, but these days, you can create all that really cool interactive stuff (see the wacky 7Up.com site) with Macromedia Flash. Since all major browsers support Flash, and since Flash runs much faster than Java ever did, it's a much better choice for creating and viewing multimedia applications.





Sure, the old QuickTime plug-in no longer works in IE 6, but that shouldn't be a problem. The first time you try to play a QuickTime file, IE 6 launches a pop-up window that lets you quickly download the updated plug-in. In a matter of minutes, you're up and running. And other plug-ins, such as Beatnik, that were affected by the ActiveX issue will probably release workable updates before you know it; there's no way any developer can ignore a browser with an 80 percent (or higher) market share.





Argument for Internet Explorer 6


Rex: No contest here: IE is, and always has been, way ahead of Netscape in implementing Web standards such as XML (Extensible Markup Language). Internet Explorer 6 continues that tradition: it provides full support for key World Wide Web Consortium (W3C) Web standards such as the DOM (Document Object Model) and CSS (Cascading Style Sheets). These technologies make it easier for Web developers to build full-featured Web applications with IE.





As for plug-ins...well, I admit I'm a bit disappointed with IE 6 in this arena. Starting with the most recent patches for IE 5.5, Microsoft decided to drop support for Netscape's plug-in architecture. Instead, Microsoft will support only its own ActiveX architecture. Since most plug-ins designed for IE use ActiveX anyway, the only major plug-in that got burned was Apple's QuickTime. That's now resolved, though---the latest QuickTime for IE works just fine.





Still, ActiveX Controls are much more plentiful and, let's face it, useful, than those you can get through Netscape plug-ins. Look at the more interesting ActiveX plug-ins such as the Google Toolbar. It's harder to get that kind of integration out of the Netscape plug-in architecture.





Dan's rebuttal: It's true that Microsoft finally made good on part of its long-standing vow to support industry standards, which may please a few Web geeks and programmers. But the rest of us won't find many neat improvements here. Frankly, I think that IE 6's exclusive ActiveX displays makes Microsoft look pretty arrogant. It's as if the developers were trying to drive home a point: It's Microsoft's world, we just live in it. Well, if you use Netscape, you don't have to--at least, not quite as much.





CNET's call: Netscape 6.2


Vote: 8-0


What a comeback! In a landslide decision, Netscape swept the support category 8-love. But, although we're jazzed about the flexibility that Netscape's open source architecture may allow in the future, our jury didn't vote for Netscape as much as we voted against IE 6. We simply could not get over Microsoft's refusal to support Java and Netscape plug-ins. It seems as if Microsoft is trying to force developers to design ActiveX plug-ins and, thus, make ActiveX an undisputed Internet standard. What's more, IE's lack of Java support severely inconveniences those of us whose favorite sites require Java to run properly. We give Microsoft eight thumbs-down.








CNET's decision: It's a tie!


Who'd have thought? After adjudicating five rounds of convincing arguments, we ended up with a hung jury. True, Netscape won the popular vote hands down. But our traditional voting process demands that we call it a tie. (Fortunately, we didn't allow any room for a third-party browser, such as Opera, to snatch votes away from either contestant.)





Although we're surprised that eight opinionated people couldn't manage to pick a victor, in terms of CNET's official reviews of the two browsers, this result makes perfect sense. Both Netscape 6.x and IE 6 scored 7 out of 10 in our official CNET reviews, each earning an equal share of bonuses and demerits. The upshot? You'll have to choose a browser based on what's most important to you. If you want tight security, Java support, and (thanks to version 6.2) support for both Windows XP and Mac OS X, go with Netscape. For a familiar, customizable interface and a simple installation process, go with Internet Explorer.





And, before Netscape and IE fans alike flood our in-boxes with irate e-mail, remember: this death match, like the others, is all in good fun. To make an in-depth, informed decision, take a close look at CNET's official Internet Explorer 6 and Netscape 6.1 reviews.


